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Section 1. Introduction

Who should take this tutorial?

This tutorial illustrates how to use the versatile Eclipse environment to facilitate
development of Globus Toolkit V4 (GT4) grid services. The tutorial is written for
Web service and grid developers who would like the convenience of
orchestrating the whole grid service development process from within the
Eclipse IDE on Windows-based platforms.

GT4 grid services can be tedious to develop because they frequently require
the developer to juggle many artifacts (source files, WSDLs, client and server
stubs, etc., many of which need to be auto-generated) and configuration steps
(various iterations of compilation, linking, deployment, etc.). Without an
integrated development environment (IDE) such as Eclipse, you must switch
between many tools (editors, command shells, file managers, build tools,
application containers, etc.) while iterating through the development process.
With the right plug-ins and configuration, the Eclipse IDE can be used to
manage all of these artifacts within a single project abstraction and coordinate
all of the useful development activities from coding to deployment to debugging.
By embedding the Apache Tomcat Web services container within Eclipse, any
updates to the grid service implementation can be immediately reflected in the
actively running grid service.

This is a tool tutorial (as opposed to a conceptual or programming tutorial) that
walks through the creation of a simple WS-Resource within the Eclipse
environment. A general familiarity with Java technology, Eclipse, Web services,
the WS-Resource Framework (WSRF), and GT4 is recommended. (See
Resources on page 47 for links to tutorials for more information regarding these
subjects.

What is this tutorial about?

This tutorial illustrates how to configure an Eclipse project to coordinate the
development of a GT4 grid service. A GT4 grid service is a Web services-based
application that manages one or more "stateful resources," making it a
WS-Resource in accordance with WSRF.

The WS-Resource model is quickly becoming the fundamental paradigm for the
newest generation of service-oriented distributed computing infrastructures. The
WSRF is a group of specifications designed to ease the burden of implementing
and maintaining complex distributed systems by providing standard ways to
interact with "stateful" resources that are abstracted as WS-Resources.

The GT4 is a WSRF-compliant set of software components (and related tools)
from which developers can build distributed systems. Because of The Globus
Alliance's depth of experience in the grid and distributed computing fields and
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the widespread use of previous versions of the tool kit, GT4 is poised to be the
premier enabling technology for grid services and applications.

In this tutorial, we are going to use the Eclipse IDE to develop, deploy, and
debug a simple stateful Web service that uses WSRF to keep state information.
This example Web service (ProvisionDirService ) exposes the local file
system's directory hierarchy to remote grid clients. (A service or collection of
services that provision file system data into a grid is a common feature set for
many existing grid infrastructure products.) It will allow you to list the contents of
the current working directory and change the current working directory.

To get or change the current working directory, the ProvisionDirService
will expose the Cwd(Current working directory) Resource Properties.

The design pattern for this grid service follows the "Singleton with
ServiceResourceHome" pattern (as opposed to other patterns like the
"Factory/Instance" pattern), meaning that this WS-Resource consists of a Web
service paired with only one resource. The singleton resource in this case is a
Java class that keeps the current working directory resource property and
returns listings for that directory.

Although the operation of ProvisionDirService is not too complex, it is
useful to illustrate the steps we'll take to configure the Eclipse project in this
tutorial, and it also lays the groundwork for creating more complicated grid
services. We will cover the following:

° Setting up the required tools and components
° Creating the Eclipse project
° Adding the project files (don't worry -- the sources for these project files are

all provided for you in Resources on page47 )
° Creating the build/deploy launch configuration that will facilitate the

automatic generation of the remaining artifacts, assembling the Grid Archive
(GAR), and deploying the grid service into the Web services container

° Using the launch configuration
° Running and debugging the grid service

(At the time of this writing, the first release of the GT4 IDE, an Eclipse plug-in
that handles some of the code generation tasks covered in this tutorial, has
been announced, but functionality is still incomplete.)

Prerequisites

To run the example from this tutorial, we'll need to obtain and install the
following components/tools. More information regarding each can be found in
the Setting up section.

° Sun Java SDK V1.4.2 (http://java.sun.com/j2se/1.4.2/download.html)
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° Eclipse IDE (http://www.eclipse.org/downloads/index.php)
° Apache Jakarta Tomcat V5.0 (http://jakarta.apache.org/tomcat/)
° Sysdeo Eclipse Tomcat Launcher Plug-in V3.0

(http://www.sysdeo.com/eclipse/tomcatPlugin.html)
° GT4 WS Core
° globus-build-service (http://gsbt.sourceforge.net/content/view/14/31/)

About the author

Duane Merrill has been developing grid computing and distributed data
integration platforms for more than five years. He has been a contributor to the
Legion Project at the University of Virginia and a core developer for the Avaki
Corporation's distributed enterprise information integration product Avaki. He is
currently obtaining his doctorate in computer science at the University of
Virginia. He can be reached at duane@duanemerrill.com.
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Section 2. Setting up

The Architecture

The Eclipse tool integration platform is a very popular, very extensible,
well-documented IDE that can be configured to host all of the useful
development activities from coding to deployment to debugging. We will use its
Java Project abstraction to manage the artifacts (source files, WSDLs, client
and server stubs, deployment configuration files, etc.) required by the
ProvisionDirService .

The coding aspect of development will be handled in the Java Perspective of
the Java Project. This Eclipse perspective provides the organization and editor
views to manage the ProvisionDirService sources.

The artifact generation/service deployment process will be handled by the
creation of a Launch Configuration that uses the Ant buildfiles supplied from the
globus-build-service and GT4 WS-Core distributions. With a single mouse-click,
this Launch Configuration will automate the process of:

° Generating the service stubs and parameter data structure classes
° Performing some tweaking to the service WSDL
° Assembling the service Grid Archive (GAR), which contains all the files and

information the Web Services container needs to deploy our service
° Deploying the GAR into the GT4 directory tree
° Deploying the GT4 WSRF into Tomcat

To completely contain the iterative (develop/deploy/debug) development
process within Eclipse, we need a mechanism for running and debugging the
ProvisionDirService . As a GT4 grid service, the ProvisionDirService
needs to be run within and managed by a Web services container. Although the
GTK ships with its own stand-alone Web services container, this tutorial
illustrates the use of the popular Apache Tomcat servlet container to host our
sample grid service because of its rich feature set that extends beyond the
simple hosting of grid services. We use the Sysdeo Tomcat Launcher plug-in to
integrate Tomcat into the Eclipse environment.

By this point, it is assumed that you have downloaded and installed the Sun
Java SDK V1.4.2. (This tutorial was written using V1.4.2.07.) Be sure to set the
JAVA_HOMEsystem environment variable to the root of the SDK installation.
This can be done by right-clicking My Computer on the Windows desktop,
selecting Properties, selecting the Advanced tab, clicking the Environment
Variables button and adding JAVA_HOMEto the list of System variables, as
shown in Figure 1.

Figure 1. Setting the JAVA_Homesystem environment variable
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The remainder of this section reviews the remaining required tools and gives an
explanation of what each tool is for, as well as helpful information on setup and
configuration.

Eclipse

The Eclipse Platform is an extensible open-source tool integration platform for
"anything and yet nothing in particular." It provides building blocks and a
foundation for constructing and running integrated software development tools.
for this tutorial, we will be using it as a Java IDE.
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The Eclipse Platform distribution should be obtained and unzipped into the local
file system. For this tutorial, Eclipse V3.0.2 was installed into the
\dev\eclipse directory .

Eclipse normally uses the Java Runtime Environment (JRE) installed in the
\Program Files\Java directory, rather than a full JDK, but Tomcat must
have access to a JDK. If you have not done so already, add the JDK to the list
of installed JREs that Eclipse knows about. Go to the Window > Preferences
menu and open the Eclipse Preferences dialog. Select the Java > Installed
JREs page shown in Figure 2. Click Add to add the JDK to the list.

Figure 2. Add the JDK to Installed JREs

Check it to make it the default, as shown in Figure 3.

Figure 3. Setting the default JDK
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Click OK to finish the configuration.

Tomcat

Apache Jakarta Tomcat is the servlet container used in the official Reference
Implementation for the Java Servlet and JavaServer Pages technologies. In this
tutorial, we use Tomcat as the Web services container for the GT4 WSRF Web
application.

The Tomcat distribution should be obtained and unzipped into the local file
system. For this tutorial, we'll install V5.0.28 in the \dev\jakarta-tomcat-5.0.28
directory.

Before we can run the "admin" and "manager" programs in Tomcat, we must
first define a user for this. Insert the following line into the
\dev\jakarta-tomcat-5.0.28\conf\tomcat-users.xml:

<user username="admin" password="admin" roles="admin,manager"/>

Sysdeo Tomcat Launcher

The Sysdeo Tomcat Launcher is an Eclipse plug-in necessary for managing the
Tomcat Web services container from within the Eclipse IDE. Although there are
several Tomcat plug-ins for Eclipse on the market, the (free) Sysdeo Tomcat
Launcher is ostensibly the most popular and well known. The Sysdeo Tomcat
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Launcher adds several menu-bar buttons to Eclipse for the starting and
stopping of the embedded Tomcat container, and also registers the Tomcat
process with the Eclipse debugger.

The Sysdeo Tomcat Launcher plug-in should be obtained and unzipped into the
Eclipse plug-ins directory. (Its features will be made available the next time
Eclipse is started.)

Before using the plug-in, we need to configure several of its preferences. Go to
the Window > Preferences menu and open the Eclipse Preferences dialog.
Select the Tomcat page. Select Version 5.x radio button and fill in the Tomcat
Home textbox, as shown in Figure 4:

Figure 4. Setting the Tomcat version

Additionally, ensure that the JVM Settings page (shown in Figure 5) are
configured to use the JDK JRE (the Preferences page may need to be closed
and reopened if it wasn't closed after setting the JDK as an Installed JRE).

Figure 5. JVM Settings page
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Finally, enter the manager role username/password in the Tomcat Manager
App page, as shown in Figure 6.

Figure 6. Tomcat Manager App page
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GT4 WS-Core

The GT4 WS-Core is the Globus Toolkit implementation of the WSRF and the
Web Service Notification (WSN) family of standards. It provides the API and
tools for building stateful Web services (WS-Resources).

The GT4 WS-Core distribution should be obtained and unzipped to the local file
system. Download the V3.9.5 source-code distribution (so we can step into and
view the WS-Core source while debugging) and unzip it into \dev\GTK.

Additionally, we need to set a GLOBUS_LOCATIONenvironment variable to
\dev\GTK; follow the same instructions as for setting the JAVA_HOME
environment variable described earlier in this section.

To build the WS-Core from source, you must first obtain the Apache Ant build
tool from (http://ant.apache.org/bindownload.cgi). To build it, open a CMD shell
and type the following:

D:\>cd %GLOBUS_LOCATION%\ws-core-3.9.5
D:\Dev\GTK\ws-core-3.9.5>ant all

This command builds and installs the WS-Core into \dev\GTK. If necessary, you
can find further build and administrative instructions for the WS-Core in the
WS-Core Administrators Guide.
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The globus-build-service

The globus-build-service distribution is a Ant buildfile (and related shell
scripts) to assist with the building of GAR files. This buildfile is a variation of the
one used in the GT4 Programmer's Tutorial (see Resources on page 47). Obtain
the distribution and unzip these files into the \dev\GTK\etc directory.

The next section illustrates how to create a new Java Project for our
ProvisionDirService and shows how to prepare the project for the addition
of the service source files.
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Section 3. Creating and configuring the project

Create a new project

We start by creating a new Java Project called ProvisionDirService .
Select File > New > Project... and select Java > Java Project from the
selection wizard. Click Next and enter ProvisionDirService in the Project
Name textbox. Accept the remaining project creation defaults by clicking Finish .

Figure 7. New Java project dialog
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Make the project a Tomcat project

The first thing we need to do is to make this project a "Tomcat Project." Doing
so enables Tomcat to run from .class files inside our project as soon as they
are compiled by Eclipse (which happens every time they are saved). Hence,
minor changes to the service logic will be reflected in the running service
without having to regenerate or redeploy any GARs. Open the project properties
page shown in Figure 8 (select Properties from the project's pop-up menu),
select the Tomcat page, and check the "Is a Tomcat Project" checkbox.

Figure 8. Project properties page

Click OK.
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Add project source to Tomcat source path

Now we need to add the project's source to the Tomcat source path. The last
step allows Tomcat to reload any updates to the implementation. This step
allows the live debugger to pull up the fresh source when debugging.

Go to Window > Preferences and select the Tomcat > Source Path page
(shown in Figure 9). Select the checkbox next to our ProvisionDirService
project.

Figure 9. Source Path page

Click OK.

Include the WS-Core classes as the GT4 Library

The second thing we need to do is to update the Java Build Path Libraries to
include the WS-Core JARs so the Eclipse editor will be able to find the WSRF
classes our grid service sources will import. Do this by opening the project
properties page (select Properties from the project's pop-up menu), selecting
the Java Build Path page, and clicking the Libraries tab. As you can see in
Figure 10, only the JRE System Library is currently imported.
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Figure 10. Updating the Java Build Path Libraries

Use the Add Library... button to add a user library and click Next .

Create the GT4 library

To create a user library from the GT4 library directory, use the User Libraries...
button. Click New... in the User Libraries dialog (see Figure 11) and create a
Library called GT4 Library.

Figure 11. Create a new user library
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Click Add JARs... and select and add all of the JARs in
%GLOBUS_LOCATION%\libto the library. Selecting OK and Finish leaves us
with the properly configured Libraries tab.

Finish the configuration

The Libraries tab should look like Figure 12.

Figure 12. Updated libraries tab
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